Reply To: dropcontroller_sketch2019_v3_005_02

Forums General Questions and Comments dropcontroller_sketch2019_v3_005_02 Reply To: dropcontroller_sketch2019_v3_005_02

#3559
Martyn
Keymaster

Hi Danny,

you may have an issue with the type of quote character used. Here is a comment from Gordon Gilfether who had the same problem.

Tried uploading the sketch to my Arduino Nano and kept getting the following error message a number of times (warning: invalid conversion from ‘const char’ to ‘char’ [-fpermissive]**).

As I couldn’t get the sketch to upload I ran the compiler tool and got the same errors which also seemed to refer to process NewData. So after trying to research and understand what the errors referred to I went into the processNewData tab on the sketch and noticed that all the references to – receivedChars [0] = “” – the zero had double quotes. I changed these to single quotes i.e.- receivedChars [0] ”- ran the complier which came back with no errors and then uploaded to Arduino Nano without errors.

I have been unable to recreated the problem on any of my computers but enough people have reported it to show it is an issue. Here is an unofficial update with all the double quotes changed to single quotes. It compiles and uploads fine but I have not tested it on an actual dropController device yet (I am not at home).

sketch_dropControllerV3_2019_005_03 (untested)

Please let me know if it works.