Testing the dropcontroller.

Forums General Questions Testing the dropcontroller.

This topic contains 11 replies, has 2 voices, and was last updated by  Craig 4 months, 3 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #2726 Reply

    Theo Bosters

    Hi Martyn….

    Being testing the dropcontrollerboard for 3 days now, everyting looks to work except the shutter goes every other sequence off.
    i noticed that when testing the shutter goes off every time when i push the shutter release half in, when i then start the dropcontroller (manual) the camera take’s a picture everytime the dropcontroller send the command.
    I think there is a error in the software that causes this problem, thinking on the focus part.
    looks like the app is waiting for the command that focus has been done, en then give the trigger command to the shutter.
    can the focus part be delete? when photographing drops you focus manual anyway.

    #2727 Reply

    Theo Bosters

    Ps. This is in BT mode, in the pc app its working perfect no problems

    #2730 Reply


    Check to see if you have selected mirror lockup on the Settings Tab. Worthwhile checking you are not in bulb mode as well.

    If it is not mirror lockup I am not sure what it could be. Both the PC app and the BT app send the same commands. The only difference is, when using a PC the Arduino is receiving data via hardware serial, and when using Bluetooth it is receiving via software serial.

    You can disable the focus trigger by commenting or deleting the relevant lines in the sketch.

    In the makeDrops sketch, search for CT_FOCUS_PIN. Where the command is on its own you can comment it:

    digitalWrite(CT_FOCUS_PIN, HIGH);
    digitalWrite(CT_SHUTTER_PIN , HIGH);
    CamTriggered = true;

    change to –
    //digitalWrite(CT_FOCUS_PIN, HIGH);
    digitalWrite(CT_SHUTTER_PIN , HIGH);
    CamTriggered = true;

    When it is part of a large line simply delete it:

    if (!CamTriggered && !camDone) { if (millis() – seqStartTime >= CT_Time_Start ) { digitalWrite(CT_FOCUS_PIN, HIGH); digitalWrite(CT_SHUTTER_PIN , HIGH); CamTriggered = true; } }

    after delete –
    if (!CamTriggered && !camDone) { if (millis() – seqStartTime >= CT_Time_Start ) { digitalWrite(CT_SHUTTER_PIN , HIGH); CamTriggered = true; } }

    There are no confirmations during the drop sequence only at the end. In brief:

    The app sends the drop data to the dropController.
    The dropController processes the drop data, creates the drops
    Sends back a message saying sequence finished.

    What camera are you using?

    #2738 Reply

    Theo Bosters

    Tested it on de canon 60D, 80D and the 5Dmk iv, all do the same, no bulb and no MLU. going to change the settings on the camera to the default settings, now i’m using back button focus, see if that solve the problem, as said on the pc site all is working fine.
    if restore the default not working then i try youre option.


    #2739 Reply


    Is the camera going to sleep? What timeout/sleep settings do you use on the cameras? I wonder if you could use the mirror lockup signal as a wakeup.

    #2740 Reply

    Theo Bosters

    solved the problem, altough on the pc app the cam trigger pulse is on 30ms by default and works everytime, when using the android app on BT, i must set the pulse time to about 100ms, maybe the reason is that one is hardware serial and the other is software related.
    when setting it to 100 ms it works also everytime till i change the settings on the camera, when i change from 1 sec shutter, to 2 sec. then i must also change the trigger pulse (only on the android site).

    #2749 Reply


    I spent sometime yesterday looking at this. Can’t figure out why you have this issue.

    The apps send timing data to the dropController only and both apps send the same data. The dropController takes the data and controls the triggers. It does the same actions regardless of where the data comes from.

    I thought it may have been a power issue (long shot) due to the BT module requiring more current when working (more power to the BT module less to the optocouplers), but all my measurements say not. The BT module is not receiving or transmitting when the drop sequence is active so its power consumption is minimal when the drops are being created.

    As I finished this comment I realized I haven’t checked the actual data

    EDIT: Checked the data. Both apps send exactly the same commands.

    • This reply was modified 8 months ago by  Martyn.
    #2756 Reply

    Theo Bosters

    i noticed that when i shorten the camera’s cable to activate the shutter, that when i doing this realy very fast the camera’s don’t react, but when i do it a little slower the work fine, this told me that the triggerpulse must be somewhat longer then the 30 ms on the BT side.
    setting it on 75ms it trigger 9 out of 10 the shutter, on 100ms its 100%.
    the only small issue is when changing the shutter speed, then i also must change the triggertime slightly.
    now i knowing this i can live with it, in practise i going to use the controller thru a laptop anyway, overall its working great now even the valve’s working fine…….

    BTW. the 3e flash, must i activate this in the sketch????


    #2758 Reply

    Theo Bosters

    after testing the board the last few day’s, its time to order the final design.
    Board is smaller then the prototype (dimensions: 107.188×102.743 mm).
    pcb dropcontroller final

    #2765 Reply


    Regarding the third flash connector. I’m not sure when I will get time to update the sketch. I was hoping to do it over the Easter break but I am working now.

    I did update the sketch at the same time I did the apps but I lost the new source code somewhere and need to do it again.

    #2771 Reply

    Theo Bosters

    i’ve tried to change the look of the pc app with the sorcefile’s in the download when i saw that there is only one flash active.
    I’m no programmer so i can change the look for the app butt can’t get the other flashes to work.
    BTW. this is the final board

    #3095 Reply


    Theo, do you have the gerber files for the final board? The file that Martyn posted in the PCB section is not this version. I like the one that is there with the dc-dc converter but the stereo audio jacks and the DC terminal jack have the center pins oriented the wrong direction, they should be orthogonal to the others but are parallel. Or if it’s possible can you update the one with the dc-dc buck converter? Thank you in advance!

Viewing 12 posts - 1 through 12 (of 12 total)
Reply To: Testing the dropcontroller.
Your information: