Camera firing twice

Forums Forum Camera firing twice

This topic contains 3 replies, has 2 voices, and was last updated by  Martyn 1 year, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2006 Reply

    Avinash

    Hi Martin,

    I’m trying single valve with single Camera point (Shutter+Focus) i.e. without any separate flash point however I’m triggering the speed light with wireless trigger attached to the camera. It works and I got some decent pics too, but, when I press start button on android app the camera gets triggered twice. First is almost immediately I click the start button and the other one as per the water drop sequence. what could be wrong here?

    #2007 Reply

    Martyn
    Keymaster

    Have you turned on mirror lock up?

    #2009 Reply

    Avinash

    Yes I did, it is more consistent with mirror lock on, but still fails to trigger only once. without mirror lock it gets triggered erratically, like only once in 2-3 clicks on start button. I suspect this could be an issue of the camera trigger wire I’m using !! which is just a 2.5mm audio aux at the camera end and 3.5 mm at the RCA/Phono sockets end of the circuit.

    #2010 Reply

    Martyn
    Keymaster

    Mirror lockup sends a pre-drop shutter trigger signal.

    Turn off ML and increase the camera trigger pulse time. The default is 50ms. Try 75ms or 100ms.

    If this doesn’t work check for lose wires.

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: Camera firing twice
Your information: